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Digital Video Work Flow and Standards
It’s best if to know how your video will ultimately be presented, how it’s being
delivered to an audience, before you start, so you can tailor your parametersresolution/size, frame rate, container and codec etc., to be compatible with the
native specs of the delivery device & environment. In lieu of that, or if you expect
to be screening across different delivery platforms, it's best to make a 'master' hires/hi-def, lossless version of your video that anticipates different
delivery/environments settings, and you can always make other versions from the
master using different settings.
Back up your work often, especially all project files, on a separate drive (project
files are the documents you've created using After Effects or Final Cut, etc., and
your source media). I highly recommend also using a cloud-based back up for
double back-up.
Resolution
The pixel dimension of the frame, higher means larger files but better
resolution for devices able to deliver them. For example, high definition (HD)
resolutions are- full HD is 1920x1080, 1280x720 small HD. Digital cinema standard
is 4K at 4096x2160 (2K is 2048x1556) as well as 8K and up, used by film industry
pros. For SD (standard def), your average SD older data/video projector’s native
resolution is 1024x768.
Aspect Ratio
The ratio of width to height of the frame, usually represented as two
numbers separated by a colon, such as 4:3 or 16:9 (wide screen)
Frame Rate and Standards
The number of frames that are shown per second (fps). The digital video standard
is 30fps or 25 fps, animation standard is 30fps. Newer production and cameras use
higher rates for supper smooth action & to facilitate slow motion. Traditional film
standard is 24fps.
The frame rate for SD video is often standardized depending on country/continent,
though this is becoming less important due to advances in video streaming
technologies. In North America, Central America and parts of South America the
standard NTSC (standard definition) frame rate is 30 fps. Technically, NTSC runs at
29.97 fps. In much of Europe, Eastern Europe, Asia, Australia
and much of Africa, the standard for regular (standard def-SD) definition video is
PAL and uses 25 fps.
NTSC and PAL also have common standard ‘resolution’ or frame sizes.
NTSC 720x486 also known as ‘D1’ (720x480)
PAL 720x576 (there is also a high def PAL format)

NTSC and PAL are size/ratio + frame rate standards that come into play mostly
when you send off videos to festivals and the like, often on dvd. If you are
streaming/playing video through a computer or display that uses (for example) VLC
or a media player, the NTSC & PAL standards are not applicable.
Formats- Containers (also known as Wrappers)
Containers are video file formats, where video files get their file extensions, and
they can contain video and audio. By definition, a container format could wrap any
kind of data. The most popular video + audio containers are Quicktime .mov,
mp4/mpeg-4, Windows .avi, Flash Video .flv. The most popular audio only
containers are .aiff (used mostly on macs), and .wav (used mostly on windows).
Containers are NOT codecs. After Effects does not like .mp3 files.
Codecs
A video codec is a device or software that enables video compression and/or
decompression for digital video (and audio). The process usually employs lossy data
compression. It’s best to choose common in-use codecs such as H.264 (the codec
of choice for many applications where you need a smaller file), DivX (older popular
codec, fading from use), mp4 video, MPEG-2, JPG 2000, DV stream, etc. New
codecs come out from time to time, but don’t use them unless you know that your
video presentation device can support it.
Codecs and Rendering
When you are editing digital video for a final product, or for use in another
application (such as final cut > after effects) it’s best if you can to work with
lossless files, and to render or export also as lossless (no compression or loss of
data), then you can export lossy versions from there that give you smaller file sizes.
However, unless you're working on a set up that allows for very large files, then
that may be difficult or impossible. The Art Dept. computers are not generally
equipped to deal with super large files. For a lossless codec when rendering from
After Effects, in the Render Queue use Best Settings & Lossless or Animation
settings. After Effects is primarily designed to create lossless, full files, that you
would then render/export down for smaller more portable files (such as
mp4/H264); though you can render out single pass mp4/h264/etc from AE as well.
Current versions of After Effects CS6 allows you to render out using it's sister
program- Adobe Media Encoder (AME), in CC this is the primary option for all
exports. AME is sometimes better, sometimes not, depending on the situation.
Bit rate
(Files that are too big are often the result of an unnecessarily large bit rate)
Bit rate controls both the visual quality of the video and its data file size. It is the
number of bits (data) that the video will process in a given period of time (usually
seconds). Bit rate is commonly measured in kilobits per second
(kbits), or megabits per second (mbits). For example, a DSL connection may
be able to download data at 768 kbits, while a Firewire 800 connection can
transfer data up to 800 mbits. Bit rate can also describe the quality of an
audio file. For example, an MP3 audio file that is compressed at 192 kbits

will have a greater dynamic range and may sound slightly more clear than
the same audio file compressed at 128 kbits. This is because more bits are
used to represent the audio data for each second of playback. Similarly, a
video file that is compressed at 3000 kbits will look better than the same file
compressed at 1000 kbits. More bits per second means more information,
more resolution, a better looking and sounding video. It also means bigger
file size. For HD video use 20,000-30,000 kbits (for vimeo uploads 10,000)
Use an audio rate of 320 when possible.
Audio
Audio files are best saved in format AIFF to ensure they import well into
editing programs (mp3’s don’t work as well). In iTunes you can select a track and
right click to ‘Create AIFF Version’. If you want to bring that .aif file into another
program (FC, AE, sound editing. etc), you can then select the .aif version in iTunes
and right click (or in File menu) to "Show in Finder" to locate the file. If you are
using a sound-editing program, like Garageband,
import (just drag it in) the .aif file to manipulate or add to other tracks. To
output your audio from Garageband use the ‘Share’ menu > ‘Export Song to
Disk’, but do not compress it unless you really have to. The export will make
an .aif file that reads well in editing programs. Audio bit rates: If your source
material is from mixed sources, then you should probably encode your audio
at the bit rate of the source that has the lowest audio bit rate; generally
though, 320 is best.
Square Pixels vs not square
Square pixel ratios are used on computers and HD (high definition) video.
The pixel aspect ratio for square pixels is 1:1. Non-square pixel ratios are
typically used in SD (standard definition) video. If you are working with SD
or mixed SD and HD footage, you may have some tweaking to do in order to
bring all ratios in line (the same) for the final project.
Progressive and Interlaced
Video can be interlaced or progressive. If your video has jagged lines, or a
“stairstep” effect, particularly when your subject is moving, this is typically
due to an interlace problem. Computer screens handle video differently than
televisions do. Playing an obviously interlaced video on a computer will look
terrible, but output that same video to a standard DVD and play it on your
old TV, it will look great. 1080i- stands for 1080 interlaced, 1080p- stands for 1080
progressive. Generally, you want progressive.
Interlaced - analog cameras and videotape
Interlaced scan-based images use techniques developed for Cathode Ray
Tube (CRT) TV monitor displays, made up of 576 visible horizontal lines
across a standard TV screen. Interlacing divides these into odd and even
lines and then alternately refreshes them at 30 frames per second. The
slight delay between odd and even line refreshes creates some distortion or
'jaggedness'. This is because only half the lines keeps up with the moving
image while the other half waits to be refreshed.

Progressive – computer and LCD displays, projectors, digital cameras
Progressive scanning, as opposed to interlaced, scans the entire picture line
by line every sixteenth of a second. In other words, captured images are not
split into separate fields like in interlaced scanning. Computer monitors do
not need interlace to show the picture on the screen. It puts them on one
line at a time in perfect order i.e. 1, 2, 3, 4, 5, 6, 7 etc. so there is virtually
no "flickering" effect. As such, in a surveillance application, it can be critical
in viewing detail within a moving image such as a person running away.
However, a high quality monitor is required to get the best out of this type of scan.
‘Deinterlace’ your files to convert interlaced files for computer,
projector, and LCD displays.
Importing Camera footage
When you connect your camera or memory card to your computer
sometimes the video footage is not directly accessible. If the camera/card
does not mount as a drive, or as, say raw or Pro Res files, but rather as a series of
folders with strange names/numbers, then you’ll need to get to your footage by
importing it. Most camera capture video will open directly through FCP/X- File>Log
and Transfer on older versions to get your footage, or file>import>media, or simply
drag and drop, on newer versions.

SUGGESTED WORK FLOW
After Effects (AE)
Before beginning your project, set up your folder/s with a main project
folder, inside that have folders for your After Effects files, your source media
(video, audio, image) files. Try not to move files around. When you move
files already in use in a project, you have to update by selecting missing file
in AE project tab and File Menu>Replace File to locate and replace.

-

Suggested settings/specs:
FPS: 30, Progressive (not interlaced)
Shoot original footage in HD, 16:9 for widescreen, or SD 4:3 ratio
Audio codec: AAC, 48kHz (cd’s use 44, but 48 is standard in digital video),
320kbps for audio if you have the option
Faster

Faster working in AE:
1. In AE Preferences>Memory
>configure Installed Ram to allot most to AE and Adobe suite
>(CS6 version):Start off by not selecting the “Render Multiple Frames
Simultaneously” option. MAYBE select it, but note that many people/systems don't
like using this because AE doesn't take good advantage of multi-core processing. If
you do use it, allot half your CPU cores to AE. The rule of thumb is that there
should be (minimum) 2GB of Installed RAM for each CPU core used.
2. While working in AE, set resolution on top of timeline to ‘auto’ or half or quarter
size instead of full, change back to full before rendering; and, set the Fast Previews
(the lightening bolt icon on the bottom of the composition window) to “Adaptive
Resolution”.
3. Use separate drives (ssd drives are best) for your applications + OS,
and to read and write files. If you only have 2 drives, you can have your
applications + OS + disk cache on the same 'main' drive, and your project files on
another. Don't forget to back up often.
A good set up though is 3 drives (professionals routinely use 5 or more)- set up like
this:
>your applications (including AE) and OS (the computer's operating system) on the
'main' hard drive of your computer
>all your project & media files on another drive (internal or external, ssd!)
>your AE disk cache on another drive (ssd!-faster is better).
Note- you can get, for example, an external 1+TB SSD drive that has the ability to
partition (or used as a RAID) into 2 virtual drives. This means you can use the one
SSD device for 2 drives.
Always back up your work (project files and renders) hourly or every time you
make a change you want to keep; remember you have the option to ‘save as’ to
keep multiple versions.
4. If you are getting a lot of buffering (spinning ball) then Purge all memory: first in
the AE menu>Edit>Purge both options, and then purge the cache in AE
menu>Preferences>Media and Disk Cache>Empty Disk Cache, and disable layer
cache. This is not great for previewing while working, but for render time and stuck
previewing only.
Render settings in AE:
1. Put caps lock ON (on the keyboard) when rendering.
2. Have already set up multiprocessing if that benefits your computer (see #1 in
Faster Working in AE).
3. Close all other programs if memory/processing power is an issue.
4. ‘Render’ (do not use the 'Export' function) video to Quicktime lossless,

Animation codec, for a master/original copy, set size and use 'best setting'.
This produces very large files, so will not be practical for many uses. If you
do use a lossless format, you can use Adobe Media Encoder (AME) to
make smaller files from the big one and/or directly render smaller files there., AME
gives you more control over settings, importantly, the ability to render H.264
and/or mp4 files with a double pass. You can also set the old Quicktime 7 Pro (not
supported on Catalina+) to double pass H.264’s. For smaller files rendered directly
from AE- use the .h264 format, High, 5.1, VBR (variable bit rate) for better quality
HD at around 30,000 mbits; use CBR (constant bit rate) of around 30 for HD for
medium quality/faster renders, resolution half or less for even smaller size files
(smaller resolution/image). If working on Mac OS Catalina+ use AME or a good
converter to make H264’s, etc.
5. Quit and restart AE if you get an error.
6. If you are having trouble with the Animation codec, try
format>Quicktime>options>ProRes+, or render in AME (can try a jpg/png
sequence there with a pre-set up folder for all the files that will make).
Quicktime 7 Pro- No longer supported on Mac OS Catalina+:
Use Quicktime 7 Pro (not Quicktime 10+).
When exporting from Quicktime to make a smaller (say H.264) version,
always use ‘Quicktime Conversion’, not ‘Quicktime Movie’.
Use the Quicktime menu Window>Show Movie Properties to extract/delete audio,
and make adjustments in Visual Settings (choose ‘high quality’ for example). You
can also trim videos in Quicktime and place more than one video in a file (drag
onto).

